Remember that as security requirements and the Internet world change, so will these requirements.  If a member is having trouble accessing It’s Me 247 features, the first step is always to upgrade the browser software. 
  • Supported browsers are the two latest versions of:  Chrome, Firefox, and Internet Explorer (PC) and Safari (on a MAC).
  • The browser must have session cookies and JavaScript enabled.
  • The browser must use 128-bit encryption.  (To check the encryption level, from the Help menu, choose Help About... and look for a cipher strength or “high-grade security” notation indicating 128-bit strength.)
  • Current usage requirements are available to members via It’s Me 247 online help. 
  • NOTE:  Because phones can vary, desktop It’s Me 247 features are not warranted on mobile devices.  For best results, use a computer with desktop It’s Me 247.